Podręcznik użytkownika CodeIgniter wersja 2.2.1


Upgrade z 2.1.4 do 2.2.0

Uwaga: Klasa Encryption wymaga teraz rozszerzenia Mcrypt na serwerze. Jeśli wcześniej używałeś klasy Encryption bez Mcrypt, to jest to zmiana, która uniemożliwi korzystanie z tej klasy. Aby upgrade'ować framework musisz wcześniej zainstalować rozszerzenie Mcrypt na serwerze. Aby uzyskac informacje na temat instalacji rozszerzenia Mcrypt, zajrzyj do dokumentacji PHP.

Zanim dokonasz upgrade'u, powinieneś przełączyć stronę w stan offline, np. poprzez podmianę pliku index.php na statyczną stonę.

Krok 1: Zaktualizuj pliki CodeIgnitera

Zamień wszystkie pliki i katalogi w folderze "system" oraz podmień plik index.php. Jeśli wcześniej dokonywałeś jakichś zmian w Twoim pliku index.php - musisz je wprowadzić na nowo.

Uwaga: Jeśli w folderze "system" (lub podkatalogach) masz jakiekolwiek własne pliki, musisz najpierw wykonać ich kopię.